"GPTXT, NMEA unknown msg" meaning

0 votes
Hello,

I have a LEA-6T and NEO-7P running in an embedded system. I can connect with U-Connect via the USB port. However, most of the text outputs are of the form:

 $GPTXT,01,01,01,NMEA unknown msg*58

There are about 50 lines of this for every normal NMEA sentence, such as GPGLL and GPRMC. In fact, it seems to be interfering with the various diagrams of the U-Connect windows application.

I've tried running "Receiver | Action | Revert Config" a few times, but it didn't stop the GPTXT messages.

Thanks!
by drossidersca asked Nov 16, 2015
8,012 views
+3 votes
Check your serial port configuration.  If the 'echo' option is enabled that will cause this problem.  in Linux you can do 'stty -F /dev/ttyS1 -echo' to disable echo then cat the gps serial device and those messages should stop.
by pete answered Feb 19, 2017
by pete selected Mar 18, 2018
Flag
Best answer
This solved the problem for me.  Raspberry Pi, July 5, 2017 Rasbian.
Thank you so much for this one comment I was going crazy looking for how to make it stop sending unknown message. Not as much experience with this stuff.
0 votes
One possible cause for this kind of behavior is a short between the Tx and Rx pins (because NMEA output messages are not recognized as input messages). I would recommend checking the resistance between these pins with a DMM to see if this is the cause.
by rmcn answered Nov 16, 2015
Thanks, I will look into that. In the meantime I modified UBX - CFG - PRT to ignore NMEA inputs, and it  alleviated the problem for the time being.
0 votes
Another likely cause after you eliminate an electrical short betwee tx and rx is if the serial port you are using is associated with a tty device that is configured to locally echo characters. That is what i encountered on my raspberry pi and it would be common to run into that on linux systems and maybe others as well.
by Chrisschwindt answered Aug 22, 2016
0 votes

Hi

do you find this problem's answer?

I have the same problem. the GPTXT messages do not stop. and i can't send any command to disable echo!

and i'm sure that TX and RX are not short circuit.

 

please let me know about your solution.

Tnx

my.wistful@gmail.com

by wistful answered May 30, 2017
stty -F /dev/ttyACM0 -echo
worked for me. I've put it in my rc.local (raspi 3)
website banner