Error installing u-center with Wine on Linux

0 votes

I am trying to install u-center on Linux using Wine but I get the following error message at the beginning:
"Only Windows Vista and above supported"

Is there any known workaround for this?

 

by jschmitz asked Dec 22, 2015
4,002 views
+2 votes

Try installing version 8.16 which still supports Windows XP. 

https://www.u-blox.com/sites/default/files/u-centersetup_v8.16.zip

by mazgch answered Dec 23, 2015
+1 vote
Hi, I just got it run on my linux laptop, with u-center 8.26. The problem "only windows vista or above supported" is probably because that wine is not configured to support Windows OS above XP, and your u-center version doesn't support WinXP as it's too old..

Try the following command:

winecfg

This is the wine configuration command. Unter Application Tab, change default XP to Win10, for example. Make sure you installed the newest version of wine.

Besides, I find it out that u-center 8.26 is much more stable than u-center 8.16. U-center 8.16 crashes upon opening packet console, binary console or test console.

I've written a post explaning how I managed this. See the following link:

https://forum.u-blox.com/index.php?qa=12530&qa_1=does-u-center-support-linux
by penguin007 answered Jul 29, 2017
0 votes
You can install u-Center on a windows PC and then simply copy the entire installation folder over to your Linux system. Then use Wine to run u-Center.exe.
by rmcn answered Dec 22, 2015
This did not work for me
0 votes
You can change the Windows API Version reported to the application using the "winecfg" command to provide another Windows Version. This worked for me and is probably the most clean way to go.

After installation, create a symlink from your serial device (/dev/ttyUSB? or /dev/ttyACM? or whatever) to ~/.wine/dosdevices/com1 and use com1 in the application.
by gibbon_ answered Jan 13, 2017
This did not work for me. The installation seems to work but when running the program it crashes. I also tried to copy an installed windows directory but got the same problem.  (Also created the symlink to com1.)

Anyone else who had similar problems and got it working? (There is no information from wine what the problem might be.)
0 votes

You need to add the group dialout for user which launch the app in order to have access to /dev/ttyUSB0 or /dev/ttyS0 on wine.

sudo adduser YOUR_USER dialout

Then create a symbolic link to ~/.wine/dosdevices/

ln -s /dev/ttyUSB0 ~/.wine/dosdevices/com1

or if you are using the serial port

ln -s /dev/ttyS0 ~/.wine/dosdevices/com5

 

by blenouvel answered Feb 2, 2017
website banner