I am trying to use the VK-172 USB U-Blox 7 reciever in Fltplan GO app for windows 10. Any Ideas?

0 votes
I can not get the app to recognize the GPS.The app uses the IP location ok as long as there is an internet connection. But I have tried both the sensor driver and the com port driver. Still not luck. The computer is a Microsoft Surface Pro 3.
by jstewart49 asked Jan 12
184 views
New information.  FltPlan Go app uses the Windows Location Sensor.  But that driver shows in the install events log:
Device USB\VID_1546&PID_01A7\6&d32dae1&0&3 was not migrated due to partial or ambiguous match.
How do I fix this?
If you are talking about u-blox driver then uninstall all u-blox drivers and then install only sensor driver.
Are you sure that the device you are using (the one that has u-blox 7 in it) routes u-blox USB port out?  Most devices would take u-blox UART and route it out with UART to USB converter - in this case u-blox drivers are not applicable.
I do not know what any of that means.  No clue what UARAT is.  All I want is for this to work.  Thanks for replying though.  Time to start over.  The selection guide for GNSS USB driver for windows states insert the USB without an internet connection.  But I did not see this first, so I can not do that. Even if I have all interconnections turned off, the sensor driver installs.  I have tried uninstalling everything, but It finds the sensor driver somewhere. How do I uninstall the whole works and start over? I tried to set a restore point, but when I try to restore, that does not work either.  I'm stumped.
I did work with the FltPlanGo support team and they told me that they had it working if they left WiFi on.  I still can not get this to work on my surface pro 3.
0 votes
Does uCenter see the device as a COM or Sensor?

What does the software expect to see? What does their support suggest either as expectations or known working devices/configurations?
by clive1 answered Jan 13
uCenter can see the device as a Sensor. Fltplan support told me that the app should be set to internal GPS. The only choice is "Windows GPS". There are ADS-B options that can be customized. All it asks for is a name and a port.  I tried uninstalling the sensor driver and installing the virtual port driver. It did show com port 3 in device manager.
This is Fltplan support comments:
The way you connect to an external GPS device on FltPlan Go is as follows:
    - Connect your tablet or laptop to the USB GPS
    - In FltPlan Go make sure that Window's GPS is selected.
When your tablet or laptop is connected to an external GPS device, FltPlan Go reads that as your internal GPS.

Please make sure that you have Location Services enabled for FltPlan Go on your device:
    - Settings - Privacy - Location.
This does not work with either sensor device or the virtual com port driver.
website banner