Using 2 u-blox device on the same PC ?

0 votes
Hi

I have a dell rugged 7414 that includes a u-blox receiver. I'd like to use this dell to evaluate a C94-M8P evaluation board. When I plug the C94 it's recognized by windows and appears in the device manager as a second "u-blox GNSS location sensor" but no new COM port appears.

I found a workaround by disabling the internal device. Looks like both u-blox devices are stucked to COM3 ?

What shall I do to be able to use this C94 more easyly ?

Thx
by apc005 asked Apr 13
188 views
PS: I can get data from the C94 but strangely the firmware update failed...
0 votes
Disable the "Sensor Driver" and just use the "Virtual COM Port" one? Frequently have multiple USB attached receivers here connected to a single PC.
by clive1 answered Apr 13
0 votes
Like clive1 says, disabling the sensor driver and using the COM port driver should work. FWIW, the Windows sensor driver, and corresponding sensor APIs, support multiple GPS's.  There are probably very few apps that use multiple GPS's though. Microsoft is in a state of application and driver chaos with regard to the legacy COM port support and the newer "sensor" driver and application support.
by ted5 answered Apr 14
First, I forgot to tell I use u-center software to evaluate my GPS u-blox chipsets. This software only uses the COMx serial ports.

I tried to disable the internal chipset WindowsSensor Driver but even if I receive data (I guess) from the externalcard on port 3 (I think it is the external one because UBX-MON-VER changes to the external card revision), I'm unable to send data to the card (assist data upload fails, firmware upgrade fails...). Isn't there away to setup the virtual COM port associated with aspecific card ? Here looks like both chipsets use the COM3...

On another PC, when I plug the external card, I get a COM10  and COM11 ports ???
I can't imagine that you have 2 GPS's on the same COM port. Windows assigns port numbers. If you have two uBlox GPS's , the VCP driver should give you 2 COM port #'s. I'm sure of this because I have 2 uBlox 8 GPS's on each of my Windows boxes. They both work fine together, both receiving and transmitting NMEA and uBlox binary. When you plug the second one in, Windows should wake up and add another COM port for it.

The only thing I can think of is that it has something to do with the Dell ublox GPS "card". Are both of your GPS's (internal DELL and external) USB?

BTW, the firmware update software in uCenter is a little touchy. If you are using USB, there is a checkbox for "USB mode" or something to that effect. You need to check this, even though the GPS is appearing as a virtual COM port.
I have 2 units :
- an internal NM8 GNSS provided by Dell wich is linked to the COM3.
- an external USB C94-M8P-3 Evaluation board

When I plug the USB device there's no new COM port but when I ask u-center for UBX-MON-VER it shows that the C94 is on the COM3 port (too ?)...

Under LINUX : I ran an "lsusb"  and it shows that the internal u-blox is USB connected (linked to /dev/ttyACM0). If I plug the external C94 it's linked too /dev/ttyACM1. Thus it's OK for Linux. Unfortunately u-center isWindows only :-((
I'm stumped.  I am running uBlox VCP driver ver. 3.3.0.0 FWIW
I finally found a solution :
- Dowload Dell drivers from http://www.dell.com/support/home/fr/fr/frbsdt1/Drivers/DriversDetails?driverId=9WX66 and extract it
- assign manually the ubloxVcp priver to the second "location sesor" (ie the C94 board)
==> it created a COM5 port that seems to work nicely (AssistNow offline successfully transfered to the flash)

Not so easy ;-)
DOES NOT WORK. COM3 and COM5 are now the external card...
I give up