Can not be able to configure via UBX-CFG command Ublox M8N module

0 votes
Hello all,


My main goal is to get only one NMEA frame - $GNRMC. But since Ublox M8N gives lots of frame, it must be configured first. So I have tried the configuration commands (UBX-CFG-XXX) as per the Ublox8 M8 Receiver Description and Protocol Specification Document but unfortunately I could not get any response form the module itself. I am sending commands over serial port.

Kindly help me to get rid of this issue.



by njasani asked May 16, 2018
0 votes
Use u-center on a Windows PC connected to the M8N either by USB or UART.
Use the UBX-CFG- MSG  commamd to turn off the messages you don't want, then UBX-CFG-CFG to save to flash memory.

Don't hack around with a hobby computer trying to compose your own commands; bite the bullet, use u-center on a PC.
u-center can show you the hex command string when you need it.
by grampy answered May 16, 2018
have got UBlox M8N from MikroE. Now I can Configure the RATE but I can not make visible only one frame (GNRMC) from the U-Centre software. Could you please guide me how to do this.? Actually , Have gone into CFG-MSG mode and select F04-NMEA-GxRMC from the drop down list then saved the configuration with CFG-CFG
You will need to enumerate through UBX-CFG-MSG and turn OFF all messages that you do not want.
Its Done. Thank you so much for the support.

Actually now my next step is to calculate distance from UBlox. So I have found the module which gives the odometer reading too. so would it be legitimate or not?
These are devices which typically don't have legitimate NEO-M8N parts in them.
website banner