Can not be able to configure via UBX-CFG command Ublox M8N module

0 votes
Hello all,


My main goal is to get only one NMEA frame - $GNRMC. But since Ublox M8N gives lots of frame, it must be configured first. So I have tried the configuration commands (UBX-CFG-XXX) as per the Ublox8 M8 Receiver Description and Protocol Specification Document but unfortunately I could not get any response form the module itself. I am sending commands over serial port.

Kindly help me to get rid of this issue.



by njasani asked May 16
0 votes
Use u-center on a Windows PC connected to the M8N either by USB or UART.
Use the UBX-CFG- MSG  commamd to turn off the messages you don't want, then UBX-CFG-CFG to save to flash memory.

Don't hack around with a hobby computer trying to compose your own commands; bite the bullet, use u-center on a PC.
u-center can show you the hex command string when you need it.
by grampy answered May 16
I have tried as per your suggestions but it can not be saved by UBX-CFG-CFG command. I have set the Baud rate and desired NMEA frame as per you have told me (By using U-Center) but When hit the UBX-CFG-CFG . Data can not be saved in its memory. When I reboot the module old parameter comes. Kindly help for the same.
Please show $GPTXT sentences that output from the receiver at startup.

Does your design include a battery or external EEPROM?
The NEO-M8N should contain a FLASH memory, setting would need to be saved in there.
12:07:06  $GNTXT,01,01,02,u-blox AG -*4E
12:07:06  $GNTXT,01,01,02,HW UBX-M80xx 00080000 *43
12:07:06  $GNTXT,01,01,02,ROM CORE 2.01 (75331) Oct 29 2013 13:28:17*4A
12:07:06  $GNTXT,01,01,02,PROTVER 15.00*01
12:07:06  $GNTXT,01,01,02,GNSS OTP:  GPS GLO, SEL:  GPS GLO*67
12:07:06  $GNTXT,01,01,02,ANTSUPERV=AC SD PDoS SR*3E
12:07:06  $GNTXT,01,01,02,ANTSTATUS=DONTKNOW*2D
12:07:06  $GNTXT,01,01,02,RF0 dev ok*04

I am using direct power supply (SMPS) of 3.3Vand no other external devices have been connected.
That doesn't look to be a legitimate NEO-M8N device as those have FLASH memory internally. Absent a battery or external EEPROM the module you have is unlikely to be able to save settings.
You mean the module I have got is not a valid?
DO i need to add external EEPROM for saving configuration data?
>>You mean the module I have got is not a valid?

>>DO i need to add external EEPROM for saving configuration data?
Yes, because you can't save it in ROM, and you'd need a battery to store in BBR
From where do I get the Original Module? I need to Buy. Can you suggest me a supplier?
One more thing is, The button cell which is mounted on PCB along with Module is of 1.7V only, do i need to insert new cell of 3.3V? Would it be a reason?
It might be a battery or a super-cap, you'd need to discuss with board vendor. It might need to be charged.

DigiKey is an authorized distributor

CSG Shop is also a legitimate supplier.
Ok I will check it out. First I will try with changing the battery cell and if it does not work either then will order new one.

Thank for the help :)
website banner