Upgrading a SARA N211 module results in AT+NBAND=20 nolonger recognised

0 votes

Has anyone encountered an issue in upgrading to the latest V100R100C10B657SP3 firmware on the SARA N211 that results in the NBAND? query returning 8 but the set (AT+NBAND=8) command returning ERROR?

When I query  AT+NBAND=?, it returns () instead of (8,20)

The previous FW V100R100C10B656 worked with AT+NBAND=20 and the SIM registered successfully on the network.

In addition to the above AT+CFUN=1 also returns ERROR where it had previously fired up successfully with the old FW.
by KillianOsullivan asked Jun 12, 2018
0 votes
Per SARA-N2 datasheet firmware has different name from what you listed.  Maybe you are running engineering version of the FW.  Per datasheet FW should be 06.57 on SARA-N211.

You may want to check with u-blox for latest FW and update your part to correct version.
by grumpy answered Jun 13, 2018
Thanks for coming back on this.  As it turns out, I believe that I was upgrading a very old version and following the UEUpdater instructions, I kept the "write config" check box clear in order not to erase the production line calibration data.  After posting the query on this forum, I went ahead and tried it again with "write config" checked contrary to the instructions and it started working.  Not sure why, but it works now.
website banner