uBlox Sara R410M

0 votes
Hi, I am having some problems with my modem. I have bought the SODAQ card with the U-blox SARA R410M-02B. When I'm using a passthrough code with a arduino the card answers for one AT-command then it just stops communicating. If i restart it it still just receives one AT-command then again stops communicating. I have 2 different cards and both are having the same issues. Also with one of the cards some AT-commands aren't persistant. I can put CFUN=0 then after about 10 seconds it puts itself to 1 automatically, this also happens if I put CEREG=1 and so on. Is there a way to restart the modem or to put it back to factory settings or something like that?
by Joelbara asked Sep 6
169 views
0 votes
I'm not familiar with the SODAQ card but it sounds like there is maybe SODAQ software controlling the modem and it sounds like the software is resetting the modem. Since neither the CFUN-0 or CEREG=2 command will persist there settings to NVM, that might explain the behavior your are observing.

There is no factory restore of the NVM on the SARA-R but AT&F resets the current profile to factory-defined defaults for the values described in appendix B of the AT command set datasheet. It's important to note that not every command displayed when you view the configuration with AT&V gets restored. Most notably, the +urat, +umnoprof, and +cops command do not get reset. Also, the SARA-R has only one profile and does not appear to support the AT&W command. I interpret that to mean that the factory default profile is restored on reset and that the AT&F command is really only of use for restoring configuration for an active session.

Long story short, yes you can restore some factory settings to default values but they probably aren't the ones you want to restore.
by jbarnes answered Sep 6
Hi JBarnes,
I dont think the SW in the SODAQ is the problem since it is a arduino code that just sends forwards messages to the Modem. I also have a N211 and its not displaying any of those problems.

Also I kind of resolved the problem of it stopping its communication from nowhere. There was some kind of problem with me setting the band in NB. When I put the band to 20 with the AT command AT+UBANDMASK=1,524288 it stopped responding. But when I changed it to something else like AT+UBANDMASK=1,8 it worked as it should again.

But it still doesn't function as it should. It still changes CFUN. If i put CFUN to 0 it changes back to 1 after around 10 s. Can  someone from U-Blox comment on this? It does the same for CEREG=1. The URC doesn't get set...

After working alot with both the N211 and R410 I feel that the R410 is very unreliable and sometimes doesn't do the things I want it to do or sometimes when I change COPS and so on it just stops responding.
Someone from u-Blox is not here, they have direct support, tied to project submissions.

Sounds like a power issue, you should perhaps be seeking first order support from SODAQ, as you have a customer relationship with them.
website banner