AT+USORD misbehaving on EVK [closed]

0 votes

We have an evaluation kit equipped with a SARA-U201 running SARA-U201-04B-00. I use this to fetch NTP time in binary format and to connect to an MQTT server. This works fine on the target device but when we run it on the the PC communicating with the EVK the USRD command regularly does not behave as expected. Here is a log from the connection and read handling.

> AT+USOCR=17, 11

+USOCR: 6

OK
> AT+USOSO=6,65535,8,1, 20

OK
> AT+USOCO=6,"pool.ntp.org",123, 29

OK
> AT+USOWR=6,48, 13

@
> [48 bytes]

+USOWR: 6,48

OK

+UUSORD: 6,48
> AT+USORD=6,48, 13
�rA�$��߲IS�Bo=߲J��=߲J�#�"

OK

Every command works fine except for socket reading where the "+USORD=<id>,<bytes>" part is missing. TCP sockets do the same where sometimes they work (IIRC) but more often than not they don't.

This is on Linux so there shouldn't be any lack of serial port buffering going on.

closed with the note: Looks like a local problem, see answer.
by marco.nilsson asked Dec 5
by marco.nilsson closed Dec 6
7 views
0 votes
I think I've figured it out. It might have been a combination between not explicitly enabling raw mode and Ubuntu's ModemManager interfering with the data polling.

 

See options at https://www.cmrr.umn.edu/~strupp/serial.html#2_5_2.
website banner