TP5 (Timepulse) configuration & MAX-7 to EVA-M8M migration [closed]

0 votes
Hello,

I experience issues with TP5 configuration since I moved my design to EVA-M8M. I send and read commands using DDC (I2C) port, and everything works fine, except for the impulse command. I need a 10MHz output, but the device seems not applying my configuration, and stay at 1Hz (default config). I double checked the configuration with u-center tool, and I'm pretty sure this is not a dry join problem, because I can measure the 1Hz pulse, and get messages from DDC bus.

Datasheets shows the device can be configured with a impulse between 0.25 Hz to 10 MHz. It should works, right ?

The module locks and I don't make mistakes between "Frequency" and "Frequency Locked", anyway I configured both with 10MHz, but the output signal remains at 1Hz.

Did I miss something? Anybody can help?

Thanks, Guenael
closed with the note: Solved the problem by myself, by adding an extra delay for M8M version.
by Guenael asked Apr 18, 2016
by Guenael closed Apr 19, 2016
114 views
0 votes
I added a delay before the call and solved the problem. No idea why EVA-M8M need extra delay, but it works...

Good day, Guenael
by Guenael answered Apr 19, 2016
website banner