Galileo satellites channel Flashers but strong signal

0 votes

Updated M8N to new firmware and the Galileo satellites show good signal but the channel number flashers and

only get fix every 1 second as shown in the picture

 

How do i get  continuous stream

 

 

by Buzzliteyear asked Jul 18, 2016
1,294 views
0 votes

I think your problem is here:

Go to MSG. 
...
Enable the following on UART1 with a rate of 5 
NAV-SVINFO 

But according to the protocol document on this command:

Send rate is relative to the event a message is registered on. For example, if the rate of a
navigation message is set to 2, the message is sent every second navigation solution. For
configuring NMEA messages, the section NMEA Messages Overview describes Class and
Identifier numbers used.

As you note, GAGSV for Galileo is not being sent, so SVINFO is your source for Galileo info.  You are getting GxGSV messages each cycle, but SVINFO every fifth cycle.  Isn't this what you are seeing?

You just need to change your SVINFO message rate to 1.

BTW, UBX-NAV-SAT is preferred, as UBX-NAV-SVINFO is only retained for backwards compatibility (see protocol spec).  And you really don't need both GSV and NAV-SAT/SVINFO, I use only NAV-SAT, as it handles multi-GNSS much better.

by WH6CTO answered Jul 19, 2016
by Buzzliteyear selected Jul 19, 2016
Flag
Best answer
Thanks SM you are Correct
I turned off SVINFO and turned on NAV-SAT Uart-1
why did the gps and glonass sats info come through with no intermittent Signal ?

https://youtu.be/jygyrTAvj-A
You were getting GPS and Glonass info via GSV messages.  The Galileo info was only in your SVINFO message, which you had set to a rate of 5 (or intermittence of 1 in 5).  I assume when you selected NAV-SAT, it has been set to 1, which is no longer intermittent.

Glad I was able to help.
yes correct it is set as NAV-SAT to rate of 1
does the NAV-SAT receiver more or less data then SVINFO ?
I need less as I think the Flight controller board its hooked to cant cope with to much and only needs minimized settings
For minimized data, you can turn off GSV, NAV-SAT and NAV-SVINFO.  Satellite info is not required for solutions.

Also, Airborne<1G is more for manned aircraft.  For UAS, there may be a better fit, but I have no experience in this area, so I suggest reading the protocol document, which explains this setting.  And a lot of experimentation.  :)

Have fun!
0 votes
The graphic is a bit blurred.

You say once a second, what update rate have you selected? Isn't Galileo limited to 3Hz from FLASH?
by clive1 answered Jul 18, 2016
0 votes

look at the second Flag down/blue one see the 4 green dashes same as the two blue flags below them again

they are about 1 second apart

Yes I set my measurement period to 333ms to get my 3 Hz but made no difference

the C/NO flashers on and off also

by Buzzliteyear answered Jul 18, 2016
Your signal strengths all look uniformly poor, suggest you get your antenna outside with a clear-view of the sky, or a better antenna. You want to be seeing >35 dB/Hz numbers
Have you tried disabling GxGSV?  Since your problem is restricted to Galileo, it could be related to mapping of satellite numbers into NMEA.
Yeah, I don't think this is an issue with how uCenter interprets GxGSV sentences.

An antenna with a view of the sky should be able to deliver 40-50 dB/Hz signals, and not have marginal lock.
I tried variations of CFG-NMEA to get GxGSV to reproduce this, and either it continuously works, or continuously doesn't.  So this is supports your statement.

I agree 30dB/Hz is low.  But I can run at these levels without ever losing lock.  Screenshots also show Qi=7, which it shouldn't be able to maintain if cycling in and out of lock.  So I don't think this is real.

Maybe this is a Tx buffer overflow?  Is this UART or USB?  In any case, look in the text console for Tx overflow messages.  GAGSV is one of the last NMEA messages, so when it happens it has a higher probability of being dropped.
I can't see the baud rate, or USB vs Serial. High update rates and copious output could cause issues, I'd start with 1 Hz and 115200 baud and work the issue from there.

I might try to replicate later, but have more pressing things to do right now.
0 votes

NEO-M8N, 3.01 FW, GPS+SBAS+Galileo, 3Hz Update rate, 115200 baud serial, North America (Chicago) via Roof Antenna.

by clive1 answered Jul 18, 2016
0 votes

Thanks so much guys for your input its Awesome I do appreciate it

I have tried disable GxGSV but it only makes the other signals broken like Galileo

I have tried 1Hz it just slows down the broken signals

I have tried outside even with stronger signal does not help

I get only 22dB from my G27 Stat and it is fine and steady as shown in picture

I do not have any  GAGSV in my text console

gps it hooked via USB

My setting have been minimized for my application ( Nav data for return to Launch model Aircraft)

How I setup below:

Go to GFG.
Select Revert to default configuration. Click Send

Go to PRT.
Set Target to 1 - Uart 1
Set Protocol In to 0+1+2
Set Protocol Out to 0+1
Set Buadrate to 57600  (or 115200 what every works)
Press Send.

Go to MSG.
enable the following on UART1 alone with a rate of 1
NAV-POSLLH
NAV-DOP
NAV-SOL
NAV-VELNED
NAV-TIMEUTC
Enable the following on UART1 with a rate of 5
NAV-SVINFO

Go to Rates.
Set Measurement period to 200 ms. (5hz)
Set Navigation rate to 1.

Navigate to Nav5
Set to Dynamic Model to Airborne<1G
Press Send.

Go to SBAS
Set Subsystem to Enabled.
 Set PRN Codes to Auto-Scan.
Press Send.

Go to GFG.
Select Save current configuration and click Send

 

 

 

 

 

 

 

by Buzzliteyear answered Jul 19, 2016
by Buzzliteyear edited Jul 19, 2016
The GPS satellites can be tracked at low dB/Hz levels, you can't however decode the navigation data from them below around 32 dB/Hz. Lower elevation satellites have longer signal path, and are more prone to having trees and physical obstructions.
0 votes

Thanks SM you are Correct
I turned off SVINFO and turned on NAV-SAT Uart-1
why did the gps and glonass sats info come through with no intermittent Signal ?

https://youtu.be/jygyrTAvj-A

by Buzzliteyear answered Jul 20, 2016
0 votes
From your video, it looks like you tested with the module on the wrist-rest of your laptop.

Please Do NOT put the antenna on your laptop...that is the worst location for kms around, just full of noise --- GNSS jamming with pulsed, modulated, broadband, EM field-shredding interference.

For first pass tests, put the antenna meters away from the laptop, and use the effective UFO repellant of aluminium foil over the laptop, AND put a good aluminium/steel/copper ground plane beneath the antenna.  After you set the baseline, the you can experiment with taking away some of the RF noise mitigation.

Good signals for some SVs may look good for C/N0 but specific noise patterns can affect specific signals--frequency domain, time domain, encoding domain, etc. can trash GNSS signals while C/N0 effects are hardly noticeable.

If, however, you placed the antenna on your laptop just for video show, then feel free to ignore all the above.

.
by grampy answered Jul 20, 2016
thanks heaps for the reply... yes the GPS module is for my model Aircraft that I had updated to 3.01 for Gailieo,so just on laptop for video reference/test...  Even Coming from a Radio control/Electronic back ground Im having trouble understanding all of you guys lingo as the GPS is a new part of my flying for me, do you have a 101 for dummy's to help learn on the web ?

cheers
Brett
website banner