Downgrading a M8N doesn't seem to work

0 votes
100 views

Hello,

Last week, I bought a pair of M8N GPS receivers. They seem genuine, the picture seems to correspond with genuine examples on the internet and flashing a firmware does seem to work. It came with firmware 3.01, however, I want to downgrade the software to 2.01 in order to use it with rtklib.

When I flash the 2.01 software from u-blox.com with u-center 8.25, the uploading seems to succeed. Here is a log where I just tried to downgrade the module

However, after uploading, the version still seems to be 3.01. Here's a screenshot of u-center. As you can see, both the 'Software version' and 'extension' boxes show software version 3.01. 

Today, I tried an older version as well, u-blox 8.20. I also tried an old FIS file, extracted from u-center 8.16. This all doesn't seem to make a difference, the board keeps running 3.01.

Is it possible that the hardware prefers loading its ROM? If so, can I 'tell' the module to boot from flash? There are people on fora telling that they successfully downgraded their M8N receivers, but I don't seem to be able to do just that. Does anyone here know how it's done?

Your help is appreciated!

Marco

asked Jun 6 by marcop23

1 Answer

0 votes
What is the base ROM version of your receiver ? u-center sends the 'delete' sequence before flashing a new version, so you may try to revert to the ROM-only first.
answered Jun 6 by helge Senior Expert
The logs indicate that it has the 3.01 ROM, not sure the 2.01 FW is designed to function on that, only the 0.22 and 2.01 ROMs

They also Indicate the part has a FLASH memory

What specifically are the markings on the NEO-M8N module?

The NEO-M8N-0-10 parts had 3.01 loaded in FLASH, but 2.01 on ROM, these parts can be readily downgraded.
It actually is a NEO-M8N-0-10. Here's a picture of the module: http://imgur.com/NJUg0Jn

But, I really cannot get the part downgraded. Also, the software version in the software monitor (screenshot in OP) tells me that 3.01 is actually in the ROM? Or am I wrong?
Sorry, i have missed the second screenshot. You have 3.01 in ROM and also in FLASH, and it seems that u-blox has prevented downgrading the firmware in such setup.
It has the 3.01, the 2.01 FLASH firmware doesn't know what that is as it significantly predates the 3.01 release, and has dependencies that can't be fulfilled.

The NEO-M8N-0-10 I have has a 2016 Week 21 build date, and a 1200 engineering number, yours is from 2017 with a 1300 engineering number. They are sold as having 3.01 FW in FLASH