NINA-B1 FW2.0 update package

0 votes
57 views

Hi,

I tried to update the NINA-B1 to the u-blox connectivity software 2.0. SWD worked fine, but update via UART (u-blox s-center) failed.

I tired to manually use nrfutil. The output is the following:

(...)> nrfutil.exe --verbose dfu serial -pkg "(...)\NINA-B11X_FW2.0.0-hex.zip" -p COM11 -b 115200 -fc
Traceback (most recent call last):
  File "__main__.py", line 303, in <module>
  File "click\core.pyc", line 716, in __call__
  File "click\core.pyc", line 696, in main
  File "click\core.pyc", line 1060, in invoke
  File "click\core.pyc", line 1060, in invoke
  File "click\core.pyc", line 889, in invoke
  File "click\core.pyc", line 534, in invoke
  File "__main__.py", line 273, in serial
  File "nordicsemi\dfu\dfu.pyc", line 66, in __init__
  File "nordicsemi\dfu\package.pyc", line 365, in unpack_package
IOError: [Errno 2] No such file or directory: 'c:\\users\\(...)\\appdata\\local\\temp\\nrf_dfu_h06p4m\\unpacked_zip\\manifest.json'

When I use "NINA-B11X-FW2.0.0.17.hex" with nRFgo Studio it creates a DFU package and flashes it onto the module, but the application won't start (no "+STARTUP" received).

I also noticed that the System Integrators manual lists two zip files, that should be included in the update package (see section 2.3.1), but there is only one.

The question is how to update to the new connectivity-software using UART? The minimum goal is to test the update process by "updating" version 2.0 to 2.0.

Thanks for the help.

asked Jun 19 by nmal

1 Answer

0 votes
Pretty sure you don't send the ZIP file
answered Jun 19 by clive1 Senior Principal Expert
Thanks for your reply.
It says to do so in the System Integrators manual, section 2.3.1. But the DFU package created from the application hex-file by nRFgo studio does not work, either.